Error: Pervasive error code 94 when registering Pastel or opening/Adding a company
Description
Pervasive Error Code 94 also known as Status 94 occurs when adding a company or registering Sage 50cloud Pastel Accounting on workstation.
Cause
Pervasive Error Code 94 also known as Status 94 is a permissions error and is caused by incorrectly configured or blocked settings on either the Sage 50cloud Pastel Accounting Server or Workstation.
Resolution
Complete the checklist below to ensure all the settings are correct on the Server and Workstation.
Follow the steps below or refer to the step by step video
Windows Administrator
Please ensure the Windows User is logged in as the local Administrator. There are certain files that will not install or will not install correctly if you are not logged in as the machines local Administrator. To check if the user is a local Windows Administrator follow the following steps:
Windows 7
Select Start...Control Panel...User Accounts ...Manage User Accounts
Windows 8 and Windows 10
Right-click in the bottom left corner of your screen, select Control Panel...User Account...Manage User Accounts
The user must belong to and Administrator Group. If the user is not, please contact your IT Administrator
User Account Control
Before installing Sage 50cloud Pastel Accounting please ensure that the User Account Control or UAC is turned off as some of the features for Sage Pastel Accounting do not function properly if the User Account Control is on. Refer to Article How do I turn off User Account Control for instructions, if needed.
Pervasive Ports
We recommend that you add the Pervasive Database Manager and Ports to your Windows Firewall. This will ensure that Pervasive and Sage Pastel can communicate effectively. Adding these Pervasive Ports can also assist in preventing specific errors and streamline the speed of the Sage Pastel program. Refer to Article How to add the Pervasive database and ports to the Windows firewallfor instructions, if needed.
Removing read only attributes
Ensure you are on the Sage Pastel Server (this is the machine where Sage Pastel is registered as the Server)
Press the Windows and E keys found on your keyboard simultaneously on the C Drive
Right click on the Pastel/Xpress folder
Go to Properties, ensure Read-only by Attributes in unticked
Select Apply and ensure the option Apply changes to this folder, subfolders and files is selected and click OK
Select the Security tab
Ensure each Group or user name under Group or user name has Full Control selected
Select OK to confirm changes
End the Pervasive Database from the task manager on the Server and the affected workstation.
NOTE: Once the repair has completed on both computers, you need to share the folder on the Pastel Server and map a drive from the Workstation to the server.
Click here to view a video of how to resolve the error 94