Error: Pervasive error code 94 when registering Pastel or opening/Adding a company
Description

Pervasive Error Code 94 also known as Status 94 occurs when adding a company or registering Sage 50cloud Pastel Accounting on workstation. 

Cause

Pervasive Error Code 94 also known as Status 94 is a permissions error and is caused by incorrectly configured or blocked settings on either the Sage 50cloud Pastel Accounting Server or Workstation.

Resolution

Complete the checklist below to ensure all the settings are correct on the Server and Workstation.

Follow the steps below or refer to the step by step video 

Windows Administrator

Please ensure the Windows User is logged in as the local Administrator. There are certain files that will not install or will not install correctly if you are not logged in as the machines local Administrator. To check if the user is a local Windows Administrator follow the following steps:

Windows 7

  1. Select Start...Control Panel...User Accounts ...Manage User Accounts

Windows 8 and Windows 10

  1. Right-click in the bottom left corner of your screen, select Control Panel...User Account...Manage User Accounts

The user must belong to and Administrator Group. If the user is not, please contact your IT Administrator

 

User Account Control

Before installing Sage 50cloud Pastel Accounting please ensure that the User Account Control or UAC is turned off as some of the features for Sage Pastel Accounting do not function properly if the User Account Control is on. Refer to Article  How do I turn off User Account Control for instructions, if needed.

 

Pervasive Ports

We recommend that you add the Pervasive Database Manager and Ports to your Windows Firewall. This will ensure that Pervasive and Sage Pastel can communicate effectively. Adding these Pervasive Ports can also assist in preventing specific errors and streamline the speed of the Sage Pastel program. Refer to Article How to add the Pervasive database and ports to the Windows firewall for instructions, if needed


Removing read only attributes

  1. Ensure you are on the Sage Pastel Server (this is the machine where Sage Pastel is registered as the Server)
  2. Press the Windows and E keys found on your keyboard simultaneously on the C Drive
  3. Right click on the Pastel/Xpress folder
  4. Go to Properties, ensure Read-only by Attributes in unticked
  5. Select Apply and ensure the option Apply changes to this folder, subfolders and files is selected and click OK
  1. Select the Security tab
  1. Ensure each Group or user name under Group or user name has Full Control selected
  2. Select OK to confirm changes

End the Pervasive Database from the task manager on the Server and the affected workstation.

  1. Right click on the Task Bar
  2. Select Task Manager
  3. Find Database Service Manager
  4. Right click and select End Task

Task Manager

 

Uninstall and Reinstall Pervasive

f the error persists, uninstall and reinstall Pervasive as an applicationon the server and workstation. Refer to article How do I Uninstall and Reinstall Pervasive Version 10 and higher for instructions.

 

 NOTE: You will need to re-register the server and then the workstations afetr the Pervasive re-install.

 

Sharing the Pastel folder

Ensure that the Pastel folder is fully shared. Refer to Article How do I share a folder for instructions, if needed.

[BCB:3:Network warning:ECB]

 

Registry Keys

Applying permissions on Current User

  1. Access the Run option by holding the Windows key and R on your keyboard simultaneously
  2. Type in regedit in the Run screen
  3. Select OK, the Registry Editor will open
  4. Double click HKEY_CURRENT_USER > Software > VB and VBA Program Settings
  5. Click once to highlight the version of Pastel where you are receiving the error i.e.. PartnerV17
  6. Right Click and Select Permissions
  7. In the Group or User names box ensure you see everyone, if Everyone is not displaying, select Add
  8. Type Everyone in the box, Enter the object names to select, select OK

9. Ensure all Groups or Users Have Full Control and Read access

10. Select Apply > OK

Applying permissions on Local Machine

  1. On the Registry Editor, select HKEY_LOCAL_MACHINE
  2. Select Edit > Find..
  3. The Find screen will display, type in Default Server and ensure all the options have been selected

4. Select Find Next

5. When the search is complete the Softline/Pastel folder will be selected

6. Right click on the Softline folder and select Permissions, apply the same permissions as in first steps

[BCB:4:Operating system warning:ECB]

 

Run a repair on Sage 50cloud Pastel Accounting 

You need to run a repair on Sage 50cloud Pastel Accounting on both the server and the workstation. Refer to Article How do I run a repair on Sage 50cloud Pastel Accounting for instructions, if needed.

NOTE: Once the repair has completed on both computers, you need to share the folder on the Pastel Server and map a drive from the Workstation to the server.

Click here to view a video of how to resolve the error 94

Refer to How do I share a folder for instructions, if needed.

Refer to How do I map a network drive for instructions, if needed.

Refer to the video How to avoid Pervasive Errors tips and tricks

Steps to duplicate
Related Solutions