Summary
Description
Your latest software update installs the components for the process to link your companies with your Sage account.
Initially you have 30 days after your install to link your Sage account and payroll companies. We refresh the connection annually, requiring you to log in with your Sage account.
In some instances, the Sage account login screen doesn't appear.
Cause
In some instances, the Sage account login screen doesn't appear.
- You don't have the appropriate permissions to install all components for the feature
Resolution
Table of Contents
Review the following steps to identify and resolve the issue.
Environmental Checks
- Check the computer/server to meet our minimum system requirements.
- If you're on a network, ensure to assign a drive letter (for example P:).
- The location can't display as a network path (like \\server\folder).
- Turn off the Windows User Account Control.
- Your computer needs an internet connection.
Software Checks
- Your payroll software release version is 2027 update 1.
- Your South African company dates are in the 2026/2027 tax year.
- View the installed versions of your additional Sage software:
- Click Search on the taskbar
- Type control and click Enter to open the Control Panel
- Click Programs and Features
- Verify the version of Sage Connected Services - the latest version is 3.0.17
- Stop and restart the Sage Connected Services.
- Test your connections for Sage Connected Services.

- Check that the program file
- SageLogin.exe is in the payroll directory
- EVS.VDB6 is in the (C:\User\username\AppData\Local\EVS\Data) directory
- Verify that the following folders appear in the payroll directory with files and sub folders:
- Runtimes
- SageLogin.exe.WebView2
- Review the registry keys on the Registry Editor (RegEdit) and make sure the following paths are correct:
- How to access the Registry Editor:
- Click Search on the taskbar
- Type regedit, then press Enter
- If prompted by User Account Control, click Yes to allow access
- Check the paths on the following registry keys:
- Computer\HKEY_CURRENT_USER\SOFTWARE\Connected Services: The EssDataPath key displays the payroll path
- Computer\HKEY_CURRENT_USER\SOFTWARE\EVS: There should be a token key entry and it should have a value
- How to access the Registry Editor:
Permission Checks
- You need the following permissions on the specific files and folders:
- Payroll Folder: You need full administrative rights, and remove "read-only" attributes
- SageLogin.exe WebView2 folder: You need full administrative rights to the SageLogin.exe WebView2 folder (Subfolder in the payroll folder)
- SageLogin.exe file: (file in the payroll folder)
- Set compatibility to run the file SageLogin.exe as administrator:
- Right-click on the file SageLogin.exe
- Select Properties, then select the Compatibility tab
- Choose “Run as Administrator"
- Click Apply, then click Okay
- Exclude the payroll system directory from active antivirus scanning:
- Ask you IT to ensure they deactivate active scans on the system folder
- Set scanning for after hours, when no-one accesses the system
Check for running instances of SageLogin.exe.
The program SageLogin.exe launches to open the Sage account login screen.
- Open Task manager:
- Right-click the taskbar (bottom of the screen)
- Click Task Manager
- Check under the processes if the Sagelogin.exe application is still running.
- Close all the running applications.
- Access the payroll again.
How to test the SageLogin.exe application:
- Open Command Prompt with administrator rights:
- In the Start Menu, type cmd
- Right-click on Command Prompt
- Choose Run as administrator
- Click Yes if prompted by User Account Control
- Change the directory to the payroll path
- Type the command: SageLogin.exe payroll and press Enter
- The expected outcome is to see the Sage account login screen
- Complete the details and click Login
You can no longer postpone connecting to your Sage account.
The onscreen message indicates the countdown days expired and you must link the Sage account.
Click Get Started and sign onto Sage Account to log into your company.

Next steps.
If the issue persists, contact Sage Customer Support for help and guidance.
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