Status 3110, 3111 and 3112 on Any File

Summary

How to resolve status 3110, 3111 and 3112 on any file error on Sage 50cloud Pastel.

Cause

Status 3110, 3111 and 3112 on any file is a result of a network-related problem.

Resolution

The below errors indicate there's a network problem.
These errors occur when there's a loss in communication between different Pervasive engines.
Although the network can be active, these errors occur in an instance when there's a drop in communication between Pervasive engines. 
You'll need to test the Pervasive communication to see where the blockage is.

View the PVSW log file:

  1. Click Start and type PVSW.
  2. Click PVSW LOG. 

Status 3110: The network layer isn't connected

The application attempted to use a network connection that was no longer active. You'll need to turn on the Pervasive engine.

Status 3111: Failure during send to the target server

The PSQL Network Services Layer attempted to send an application request to the target server and encountered a network-specific error from the target. You'll need to Add the Pervasive database and ports to the Windows firewall.

Status 3112: Failure during receive from the target server

The PSQL Network Services Layer attempted to receive data from the target server and encountered a network-specific error. You'll need to Add the Pervasive database and ports to the Windows firewall.

 NOTE: If there's a problem with AutoReconnect, You'll get a status code 3131. 

Solution Properties

Solution ID
230731083108423
Last Modified Date
Thu Oct 02 08:33:32 UTC 2025
Views
0