Skip to content
logo Knowledgebase

ERROR: Cannot roll into May 2025 under Classic/Premier 6.3b

Created on  | Last modified on 

Summary

How to solve the error when you aren't able to start a new pay period to May (Sage VIP Classic or Sage VIP Premier).

Description

You’re attempting a Start New Period from April 2025 into May 2025. The message displays and aren't able to continue with the process.

 EXAMPLE: 

Image

Cause

You can't start the new pay period (May) on the current software version.

The payroll is currently not on the latest release. Update your system to start the next calendar payroll month.

Resolution

Follow these steps to update and review your current payroll values:

  1. Review the latest software version for the current period.
  2. Log in to the Sage Portal.
  3. Locate the latest software update version.
  4. Download the installation notes and release notes to review.
  5. Download the software installation file.
  6. Install the latest version on of your Sage software.
  7. Statutory values recalculate according to the latest tax tables.

CAUTION: You processed on the previous year's tax tables and rates on your current software version. The new software recalculates all statutory values at the current rates and results in differences.

  1. Review the Medical Aid Tax Credits on the Medical Aid History screen (if applicable).
  2. Review and correct Reimbursive Travel transactions processed at the previous year's prescribed rate. Review the articles below if you need to fix the transactions:
  3. Review the PAYE, SDL, UIF and ETI values for differences.
  4. Balance your values back to the amounts paid payslips if there are differences. 

 NOTE: Contact your Business Partner for assistance with these steps.

Related Solutions