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e@syFile error: "Monthly Calculated ETI (7004): If Year of Assessment (3025) is 2022 and ETI Month (7006) equal to 08, 09, 10, or 11 and ETI SEZ code (7009) is not completed and employee's age for the specified month is less than 18 or greater than ...."

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Summary

This article will provide guidance on resolving the SARS e@syFile error, when importing your IRP5/IT3a payroll file generated on Sage VIP Classic and Sage VIP Premier.

Description

Example of the error message:

Monthly Calculated ETI (7004): If Year of Assessment (3025) is 2022 and ETI Month (7006) equal to 08, 09, 10, or 11 and ETI SEZ code (7009) is not completed and employee's age for the specified month is less than 18 or greater than / equal to 30 then this field MUST be zero (0.00), (YoA3025=2022, 7004=657.10, ETI Month 7006=09, Age=103, 7009=NOT COMPLETED, 7005=1)
  • 3025 - Year of Assessment, which would be 2022.
  • 7004 - ETI amount calculated on the payroll
  • 7005 - ETI qualifying cycle (1 = 1st 12 months qualified, 2, for 2nd 12 months, and 3 for additional relief periods August to November 2022)
  • 7006 - ETI month (1 = January, 2 = February, 3 = March, 4 = April, 5 = May, 6 = June, 7 = July, 8 = August, 9 = September, 10, = October, 11 = November, 12 = December)
  • Age - The employee age based on the date of birth
  • 7009 - Special Economic Zone (SEZ) code

Cause

The issue is possibly related to two issues:

  • The employee's age is older than 100
  • The ETI Set is supposed to be 3 but was changed to 1

This is only for the 2022 tax year.

Resolution

Solution - Employee age greater than 100:

The issue impacts employee born after 1999, where the records were created on 5.7a when the ID number was entered first. The birth century defaulted to 19 and not 20 (E.g. 1903 and not 2003)

  • Access the impacted employee's Information screen (IS)
  • Correct the Date of Birth to reflect the correct century aligned to the employee's ID number

Solution - Value of 7005 - 1 where the employees is older than 29

The solution to resolve the error, is to correct the ETI periods using the ETI Validation Utility for the affected pay periods.

Step 1: Identify the employee from the Import Payroll File Log on SARS e@syFile

  • When a payroll IRP5 file is imported but rejected, the errors are logged on the Import Payroll File Log.
  • The log will indicate the employee tax certificate records affected 
  • The error message will indicate which calendar month is causing the error (in this example, the month is September), where the employee's age is greater than 29, and the value of 7005 is 1 (and not 3 as expected):  

Monthly Calculated ETI (7004): If Year of Assessment (3025) is 2022 and ETI Month (7006) equal to 08, 09, 10, or 11 and ETI SEZ code (7009) is not completed and employee's age for the specified month is less than 18 or greater than / equal to 30 then this field MUST be zero (0.00), (YoA3025=2022, 7004=657.10, ETI Month 7006=09, Age=61, 7009=NOT COMPLETED, 7005=1)

 

Step 2: Export the ETI History from the payroll and correct the values and correct the values

  • Generate the EMP501 report from your History Reports, and review your values. 
  • Click here for a guide to export the EMP501 report.
  • Click here for a guide to export the Test run with the IRP5/IT3a Report.
  • When your Test file imports successfully, you can continue to generate your Live Run to import into SARS e@syFile.