Summary
How to resolve the validation error SDL Reference Number Invalid on Sage Business Cloud Payroll Professional
Description
You are generating the IRP5 files for either the Annual or Interim SARS Submission and instead of creating the IRP5 files the system informs you there is mandatory information outstanding. A report will then print with a list of errors and this error is in the report.
Cause
This usually happens when the incorrect PAYE number has been captured on the Basic Company Information Screen.
Resolution
- The SDL reference number is the not the same as the SDL registration number. The SDL reference number is a copy of the PAYE nr but then the first number (7) has been removed and replaced with an L.
- Ensure the Employer details are completed correctly (PAYE, SDL and UIF numbers) with no spaces in front of the company name
- The PAYE must start with a 7 (not a 9), and the UIF and SDL reference numbers must be the same as the PAYE number, with the 7 replaced with a U for UIF, and replaced with a L for SDL
- Complete the IRP5 contact person details, with no spaces in front of any fields
- Complete the Company physical address fields, with no spaces in front of any of the fields