Skip to content
logo Knowledgebase

ERROR: Cannot send email, please check email settings

Created on  | Last modified on 

Summary

How to solve the error 'Cannot send email, please check email settings' in Sage 50cloud Pastel.

Description

After installing the latest Windows update, customers experience issues sending emails from Sage 50cloud Pastel. Emails may either be saved to Drafts or fail to send with the error message:
“Cannot send email, please check email settings.”

Cause

A recent Windows update introduced changes to configuration settings that affected the Newmail.dll integration between Sage 50cloud Pastel and Microsoft Outlook.

Resolution

This issue can be resolved by replacing the outdated Newmail.dll file with an updated version.

  1. Download the new Newmail.dll.
  2. Close Sage 50cloud Pastel, and Outlook.
  3. Hold the Windows key + E to open File Explorer.
  4. Depending on where your installation is located.
    • C:\Program Files (x86)\Common Files\Sage Pastel
    • C:\Program Files\Common Files\Sage Pastel
  5. Find the Newmail.dll then right-click and select Rename.
  6. Change the name to Newmail.old.
  7. Unzip the file you downloaded/received.
  8. Copy the new Newmail.dll into the same folder where the old one was.
  9. Open Sage and Outlook again.
  10. Send an email to confirm the solution.