Summary
How to resolve the IRP5 validation error 'Income for previous tax year, no assessment year given' on Sage Payroll Professional. The error appears when running the IRP5/IT3a report.
Description
You’re generating the IRP5 file for submission to the South African Revenue Service (SARS). The validation error appears on the report and doesn't generate the IRP5 file.
Cause
You've terminated the employee in a previous tax year. The employee received income during the tax year. There was no assessment year captured on the employee's Statutory Details screen.
Resolution
Determine the assessment year
- You’ll need to review and determine for which assessment year to report the income:
- A previous tax year
- The current tax year
- Review and discuss with your business Partner or Discuss with your tax adviser
Income accrues to a previous tax year
- The income has a directive with an assessment year linked.
- From the Main Menu, go to the Employee, then select Change Employee.
- Select the employee from the list.
- Clink Statutory Details tab.
- Enter the assessment year as per the tax directive.
- Change the tax status to Temporary Tax.
Income accrues to the current tax year
NOTE: Don't activate the terminated record, as you'll lose information on the record.
- Create a new record for the employee in the current tax year.
- Set the record's start and end date within the current tax year.
- Process the income (for example, variable income) on the new record.
- The system taxes the income on the current year tax tables
- You'll need to do a History Screen adjustment
- To process the earnings for the specific month, you paid
- Process deductions and company contributions
- Remove the income on the terminated record.
- You'll need to remove the all the values on the History Screen
- This clears all values on the
CAUTION: History Screen changes don't change the 12-Month report and Equity History screen values.