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Validation Error: "Amount for code XXXX is negative (-xxxx.xx)"

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Summary

How to resolve the validation error Amount for code XXXX is negative (-xxxx.xx) on Sage Business Cloud Payroll Professional

Description

You are generating the IRP5 files for either the Annual or Interim SARS Submission and instead of creating the IRP5 files the system informs you there is mandatory information outstanding. A report will then print with a list of errors and this error is in the report.

Cause

The error indicates that the value on the mentioned IRP5 code, is negative. As per the SARS BRS specifications, no IRP5 code can be negative. Every month, during Start of Period, the system does a negative YTD validation, indicating issues which will fail the IRP5 export. It is recommended to investigate these during the year and resolve as they arise.

Resolution

  • Review why there is a negative IRP5 code on the payroll.

NOTE: Negative income can only be offset against other income received against the same IRP5 code.

  • Is the income for the current or previous tax year?
  • You cannot reduce the current tax year income with income received for a previous year.

EXAMPLE: An employee was terminated in March and owes the company money, but there has been no income for the tax year.

  • If you are doing the Interim SARS submission and you are already in September, you will have to make History Screen Adjustments.
  • If you are doing the Annual SARS submission, you can do a YTD Correction on the payslip.