Skip to content
logo Knowledgebase

Validation Error: "Code 3825 cannot have a value if code 4473 has no value"

Created on  | Last modified on 

Summary

How to resolve the validation error Code 3825 cannot have a value if code 4473 has no value on Sage200c VIP, Sage Classic, Sage Premier.

Description

You are generating the IRP5 files for either the Annual or Interim SARS Submission and instead of creating the IRP5 files the system informs you there is mandatory information outstanding. A report will then print with a list of errors and this error is in the report.

Cause

This usually happens when adjustments were made to the Provident fund company contributions during the year. IRP5 code 3825 refers to the perk that calculates when an employee has a Provident Fund Company Contribution, IRP5 code 4473. The Provident Fund cannot have a Perk if the Company Contribution amounts are zero.

This issue could also arise when employees are transferred between payrolls and the setup of the retirement funds are on different deduction and company contribution lines. Sometimes there could be no retirement fund line in the new payroll.

Resolution

Please make a data backup of the company before proceeding. Then follow the steps as outlined below:

From the main menu:

  • Select Payroll 
  • Payslip Screen
  • Select the employee code
  • Select the Taxable Benefits (Perks) Tab
  • Determine if you have a DC, DB, or Hybrid (DC&DB) fund, and depending on the type of Provident Fund, there is likely a YTD+ value on either line 22, 23, or 24.

  • With this validation error, the Perks Screen will have values but there will be no Company Contribution amount
  • From the employee payslip screen, select the HS button
  • Check if there were any negative amounts for the Provident Fund in any month, which was meant to offset a previous month (this is how the YTD+ value for Provident Fund company contributions could be zero)
  • Confirm that there should have been no company contributions towards the fund, then clear the monthly amounts on the History Screen
  • If no values appear on the Company Contribution Provident fund in the same period as the perk, type in any value in the Company provident fund field hit enter, then remove the value.
  • By removing the company contributions to Provident Fund, the perk will automatically clear


If you have a scenario where an employee was transferred between payrolls and there is a perk value for Provident Fund, yet there is no Provident Fund contribution line, you will have to set one up.

From the Main Menu:

  • Payroll 
  • Definitions
  • Deduction Definitions
  • Change mode and create a Provident Fund line
  • Then access the employee Payslip Screen
  • Select the RF button to access the Retirement Fund information
  • Employee Scheme Maintenance
  • Link the employee to the Default Provident Fund, close
  • Then Delete the fund thereafter
  • This will cause the Provident Fund information (including the Perk) to clear from the RF screens


A situation may also arise where an employee would have been mistakenly linked to two schemes. To check and correct this, take the following steps:

From the Main menu:

  • Payroll
  • Payslip Screen
  • Select the employee with this issue
  • Click on the RF button at the top
  • Click on Employee Scheme maintenance
  • Highlight the incorrect scheme
  • Click on delete
  • The HS screen perk should then be removed automatically, after deleting the scheme

NOTE:  Any History Screen adjustments will cause recalculations to PAYE in the current period. Please check the tax before and after changes, and make adjustments accordingly.