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Error: 'Runtime error 429 or 9' - when printing or emailing documents

Created on  | Last modified on 

Summary

In this article you will learn step by step how to resolve the error 'Runtime error 429 or 9' when trying to print or email customer/Supplier documents in Sage 50cloud Pastel Accounting.

Description

This issue normally occurs on Windows Server Operating systems.

Cause

This issue is caused by the desktop experience not being installed/enabled.

Resolution

When trying to print or email customer/supplier documents you may receive a runtime error 429 or runtime error 9.  This article is for when the error mentioned above happen on all documents that are printed or emailed. There is a seperate article for when the error occours on specific documents.  

 

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If you open the Forms assistant or Forms Designer and attempt to add a logo to a form, you will receive the below error:

 

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  1. Firstly, attempt to print/email a customer/supplier document in the _DEMO company
  2. If you are running a multi-user environment, login in to the company dataset on another user’s machine and attempt to print/email the customer/supplier document
  3. Should the document print in the DEMO company or via another user’s machine, close your software
  4. Hold the Windows key + E on you keyboard to access the file explorer
  5. Right click on This PC and select Properties

 

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6. Under Windows Edition check with Windows Server Edition the computer is running

7. Click on the links to the Server Edition you are running for steps on how to install/enable the desktop experience 

For Windows Server 2008
For Windows Server 2012
 For Windows Server 2016

NOTE: The above solution if when printing or emailing DOCUMENTS and will not work if you are receiveing an error 429 or 9 else where in the system.

 Should this solution not work please leave a comment and advise where you got stuck.