ERROR: Runtime error 5 when opening a company

Summary

How to resolve runtime error 5 when opening a company in Sage 50cloud Pastel.

Cause

Company folder name is greater that eight characters or if there's a problem in the Windows registry.

Resolution

Step 1: Rename the company folder

  1. Go to the machine registered as the Pastel server.
  2. Press Windows key + E to open File Explorer.
  3. Navigate to Local Disk (C:).
  4. Open the PastelXX or XpressXX folder.

    EXAMPLE:

    Pastel19 or Xpress19 where x represents the version number.

     

  5. Locate the company folder.
  6. If the folder name is longer than eight characters, right-click it and select Rename.
  7. Enter a shorter name.

NOTE:

For Xpress Start-Up, you are limited to one company. You must run the Reset Utility to remove the old company before proceeding.


Step 2: Run the Reset Utility (if the issue persists)

  1. On the Pastel server, open File Explorer and go to Local Disk (C:).
  2. Open the PastelXX or XpressXX folder.
  3. Double-click ResetXX.exe.
    • Example: Reset19 for Pastel19.
  4. Select the following options:
    • Clear Companies
    • Clear Registry
    • Clear Registration

If you need to add more users or companies to Sage 50cloud Pastel, leave your details, and we'll be in touch.

 

Solution Properties

Solution ID
200129132101650
Last Modified Date
Mon Apr 20 13:26:01 UTC 2026
Views
0