Error: There is no data for specified range
Description
Cause

This error occurs when there's a space in a customer or suppliers name or when your filters are incorrect. It's mostly received when running statements.

Resolution

Checking the customer or supplier names

  1. Go to Customers or Suppliers then Lists.
  2. Click List of Customers or Suppliers.
    • The list won't show in alphabetical order
    • The account with a space before the name will show on top
      Show the Morningview Bicycles account at the top above the A accounts.
  3. Click the account to open it.
  4. Remove the space in the front of the Name and click Save.

Checking filters

  1. Go to Customers or Suppliers then Reports.
  2. Select Statements.
  3. Select the customer or supplier account or range.
    • To select all customers, leave the From and To blank
  4. For Category select the first category at From and the last category at To.
  5. Select the date range.
    • You'll receive the error if the account has no transactions
  6. Select if you want to see all transactions or balance forward.
  7. Choose if you want allocated invoices excluded and if you want a detailed view.
  8. Don't select Zero, Negative or Less than.
  9. Click View Report.

If you can view the statement but receive the error when emailing, this indicates a problem with the Statement Distribution.

  1. Go to Customers or Suppliers then Lists.
  2. Click List of Customers or Suppliers.
  3. Make sure you set Statement Distribution to Email or Print and Email for all accounts.
  4. Ensure the email address is correct.
Steps to duplicate
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